Help Centre Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 11, 2018 - 17:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jul 11, 2018 - 16:49 EDT
Investigating
https://www.marketcircle.com/help is currently returning an internal server error. We are investigating the cause.
Posted 3 months ago. Jul 11, 2018 - 16:23 EDT
This incident affected: Main Website.