Account Manager not accessible
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 29, 2019 - 11:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 21 days ago. Aug 29, 2019 - 09:55 EDT
Investigating
We are currently investigating this issue.
Posted 22 days ago. Aug 29, 2019 - 09:05 EDT
This incident affected: Daylite Cloud (Account Manager).