Billings Pro invoicing
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 10, 2018 - 14:36 EDT
Identified
Some users have reported that they are unable to invoice. This should only be affecting a small number of users, and we are aware of the cause. We are in the process of implementing a fix.

Thank you for your patience.
Posted 4 months ago. Jul 10, 2018 - 13:10 EDT
This incident affected: Billings Pro (Billings - Numbering Service).