Billings Pro Database Maintenance
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 05, 2019 - 20:33 EST
Monitoring
We are performing maintenance to Billings Pro databases. Sync may be unavailable for short periods during this time.
Posted 4 months ago. Feb 05, 2019 - 14:01 EST
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Control Panel).