DAV Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Feb 03, 2022 - 09:58 EST
Investigating
We are currently investigating this issue.
Posted Feb 03, 2022 - 09:12 EST
This incident affected: Daylite (CalDAV and CardDAV).