Outage
Incident Report for Marketcircle
Resolved
The outage has been resolved.
Posted 7 months ago. Jan 22, 2019 - 09:33 EST
Investigating
We are investigating an issue with Account Manager. We will post updates as we learn more.
Posted 7 months ago. Jan 22, 2019 - 09:26 EST
This incident affected: Daylite Cloud (Account Manager).