New Signups not being processed
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 30, 2019 - 11:10 EDT
Investigating
Accounts being created from the website are currently failing to finalize. We are looking into the cause.
Posted 23 days ago. Sep 30, 2019 - 11:03 EDT
This incident affected: Daylite Cloud (Signup).