Network Issues
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 15 days ago. Mar 10, 2019 - 18:32 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Mar 10, 2019 - 18:08 EDT
Investigating
We are currently investigating a network issue affecting Daylite and Billings Pro.
Posted 15 days ago. Mar 10, 2019 - 17:52 EDT