Intermittent Latency
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 07, 2017 - 08:07 EDT
Monitoring
We are currently experiencing some intermittent latency with our ISP. Some services may be slower than normal.
Posted 3 months ago. Sep 06, 2017 - 23:02 EDT