Email delivery delayed
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 15:26 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2019 - 14:17 EST
Investigating
Emails such as password resets can be delayed for a long period of time.
Posted Dec 02, 2019 - 12:59 EST
This incident affected: Daylite Cloud (Email Delivery).