Account Manager Login fails
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Sep 23, 2019 - 13:23 EDT
Identified
We are investigating an issue where logging into Account Manager fails for some customers
Posted Sep 23, 2019 - 09:32 EDT
This incident affected: Daylite Cloud (Account Manager).