Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 14, 2018 - 02:36 EST
Investigating
We are investigating an outage. We will post updates as we learn more.
Posted about 1 month ago. Nov 14, 2018 - 02:32 EST
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync, Attachments).