Service Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 14, 2019 - 12:44 EST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Feb 14, 2019 - 11:59 EST
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Control Panel) and Daylite Cloud (Mac & iPhone/iPad Sync, Attachments, Account Manager, CalDAV and CardDAV, API, Migrations).