Website Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 8 days ago. Dec 06, 2018 - 14:53 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 8 days ago. Dec 06, 2018 - 14:39 EST
Update
We are continuing to investigate this issue.
Posted 8 days ago. Dec 06, 2018 - 14:28 EST
Investigating
Account manager and help centre are experiencing an outage. We are currently investigating this issue.
Posted 8 days ago. Dec 06, 2018 - 13:58 EST
This incident affected: Main Website.