Billings Pro Outage
Incident Report for Marketcircle
Resolved
The outage has been resolved.
Posted 8 months ago. Feb 18, 2019 - 08:19 EST
Investigating
We are investigating an outage. We will post updates as we learn more.
Posted 8 months ago. Feb 18, 2019 - 08:02 EST
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Numbering Service, Billings - Documents Service, Billings - Control Panel).