Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 29 days ago. Oct 19, 2018 - 23:10 EDT
Investigating
We are investigating an outage. We will post updates as we learn more.
Posted 29 days ago. Oct 19, 2018 - 19:31 EDT