E-Mail Outage
Incident Report for Marketcircle
Resolved
The outage has been resolved.
Posted 2 months ago. Jul 12, 2019 - 04:45 EDT
Investigating
We are investigating an outage with Daylite E-Mails.

We will post updates as we learn more.
Posted 2 months ago. Jul 12, 2019 - 04:39 EDT
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync).