Billings Pro Login and Sync Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 18:05 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 08, 2020 - 17:59 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync).