Daylite Signup Issues
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Sep 10, 2020 - 13:59 EDT
Identified
Users are currently not able to signup for new Daylite accounts
Posted Sep 10, 2020 - 13:39 EDT
This incident affected: Daylite Cloud (Signup).