Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 2 months ago. Feb 05, 2019 - 09:59 EST
Investigating
We are investigating an issue with Account Manager. We will post updates as we learn more.
Posted 2 months ago. Feb 05, 2019 - 09:52 EST
This incident affected: Daylite Cloud (Account Manager).