Billings Pro unable to Login
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 28, 2018 - 14:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jun 28, 2018 - 13:36 EDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jun 28, 2018 - 13:34 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync).