Billings Pro Performance Issues
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 13 days ago. Jun 11, 2018 - 13:11 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 13 days ago. Jun 11, 2018 - 12:59 EDT
Update
We are continuing to investigate this issue.
Posted 13 days ago. Jun 11, 2018 - 12:27 EDT
Update
Some customers will now be experiencing trouble connecting.
Posted 13 days ago. Jun 11, 2018 - 11:46 EDT
Investigating
We are investigating slow performance for some Billings Pro users.
Posted 13 days ago. Jun 11, 2018 - 11:24 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Documents Service).