Website Partial Outage
Incident Report for Marketcircle
Resolved
The outage has been resolved.
Posted May 11, 2018 - 13:29 EDT
Investigating
Parts of the marketcircle.com website are down. We are investigating.
Posted May 11, 2018 - 13:20 EDT
This incident affected: Main Website.