Account Manager Unavailable
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 15 days ago. Nov 29, 2018 - 11:20 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 15 days ago. Nov 29, 2018 - 09:38 EST
Investigating
We are currently investigating this issue.
Posted 15 days ago. Nov 29, 2018 - 09:28 EST
This incident affected: Daylite Cloud (Account Manager).