Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 21:34 EDT
Identified
We are investigating an outage. We will post updates as we learn more.
Posted Jun 08, 2020 - 21:03 EDT
This incident affected: Daylite Cloud (Signup, Mac & iPhone/iPad Sync, Attachments, Account Manager, Email Delivery, Migrations).