Billings Pro not accessible to some customers
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Sep 02, 2020 - 17:09 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 02, 2020 - 15:31 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Numbering Service, Billings - Documents Service).