Billings Pro Sync Partial Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 22, 2019 - 14:25 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Feb 22, 2019 - 14:12 EST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Feb 22, 2019 - 13:57 EST
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync).