Billings Pro invoicing failures
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Feb 24, 2020 - 17:15 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2020 - 16:47 EST
Investigating
We are currently investigating this issue.
Posted Feb 24, 2020 - 16:21 EST
This incident affected: Billings Pro (Billings - Numbering Service, Billings - Documents Service).