Website Outage
Incident Report for Marketcircle
Resolved
The outage has been resolved.
Posted 3 months ago. May 11, 2018 - 13:13 EDT
Investigating
We are investigating an outage. We will post updates as we learn more.
Posted 3 months ago. May 11, 2018 - 13:06 EDT
This incident affected: Main Website.