E-Mail Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 17, 2019 - 03:49 EDT
Investigating
We are investigating an issue where some customers can't access E-Mails. We will post updates as we learn more.
Posted about 1 month ago. Jun 17, 2019 - 03:16 EDT
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync, API).