Billings Pro Emergency Maintenance
Incident Report for Marketcircle
Resolved
The emergency maintenance is complete.
Posted 11 days ago. May 11, 2018 - 20:17 EDT
Investigating
Billings Pro will be unavailble for some customers for up to 20 minutes as we perform some emergency maintenance.
Posted 11 days ago. May 11, 2018 - 20:12 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync).