Billings Pro Password Reset Email Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted about 1 month ago. Nov 12, 2018 - 22:30 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Nov 12, 2018 - 22:25 EST
Identified
The issue has been identified and a fix is being implemented.
Posted about 1 month ago. Nov 12, 2018 - 19:32 EST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Nov 12, 2018 - 19:03 EST
This incident affected: Billings Pro (Billings - Control Panel).