Billings Pro Web Interface Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 7 months ago. Feb 01, 2019 - 10:13 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 7 months ago. Feb 01, 2019 - 10:02 EST
Investigating
We are currently investigating this issue.
Posted 7 months ago. Feb 01, 2019 - 09:50 EST
This incident affected: Billings Pro (Billings - Control Panel, Billings - Website).