Sync Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 30, 2019 - 06:12 EDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 30, 2019 - 03:56 EDT
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync).