On-Demand Email Upload Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 29, 2019 - 15:37 EST
Identified
The issue has been identified and a fix is being implemented.
Posted 5 months ago. Jan 29, 2019 - 15:28 EST
Investigating
We are currently investigating this issue.
Posted 5 months ago. Jan 29, 2019 - 15:08 EST