Outage
Incident Report for Marketcircle
Resolved
The outage has been resolved.
Posted about 1 month ago. Sep 18, 2019 - 07:42 EDT
Investigating
We are investigating an outage. We will post updates as we learn more.
Posted about 1 month ago. Sep 18, 2019 - 07:33 EDT
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync).