Billing and Payment unavailable.
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Jun 12, 2020 - 14:22 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2020 - 13:29 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 12, 2020 - 12:59 EDT
Investigating
We are currently investigating an issue where some customers are unable to view their invoices or change their payment details in Account Manager.
Posted Jun 12, 2020 - 12:55 EDT
This incident affected: Daylite Cloud (Account Manager).