Billings Pro Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 09:51 EDT
Investigating
We are investigating an outage. We will post updates as we learn more.
Posted Jun 09, 2020 - 09:28 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Numbering Service, Billings - Documents Service, Billings - Control Panel, Billings - Currency Service).