Billings Pro Login Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 16 days ago. Nov 27, 2018 - 18:10 EST
Investigating
We are currently investigating this issue.
Posted 16 days ago. Nov 27, 2018 - 17:24 EST
This incident affected: Billings Pro (Billings - Desktop Sync).