CalDAV/CardDAV Authentication issues
Incident Report for Marketcircle
Resolved
The issue has been resolved.

If the error message still shows up, try to restart the Calendar or Contacts app or select "View->Refresh Calendars" in Calendar.app.
Posted 8 days ago. Aug 14, 2019 - 09:39 EDT
Investigating
Some customers are currently receiving an "Incorrect Password" error using CalDAV and CardDAV, even when the correct password is provided.
Posted 8 days ago. Aug 14, 2019 - 09:13 EDT
This incident affected: Daylite Cloud (CalDAV and CardDAV).