Billings Pro Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 29, 2018 - 16:53 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jun 29, 2018 - 16:44 EDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jun 29, 2018 - 16:33 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync, Billings - Control Panel).