Billings Pro iOS and MacOS Sync issues
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted Sep 17, 2020 - 19:12 EDT
Update
We are continuing to investigate this issue.
Posted Sep 17, 2020 - 19:12 EDT
Investigating
We are currently investigating this issue.
Posted Sep 17, 2020 - 15:34 EDT
This incident affected: Billings Pro (Billings - Desktop Sync, Billings - iPhone/iPad Sync).