Issue with Daylite E-Mails
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 27 days ago. Jul 19, 2018 - 16:44 EDT
Identified
We are investigating an issue with E-Mails in Daylite
Posted 27 days ago. Jul 19, 2018 - 16:25 EDT
This incident affected: Daylite Cloud (API).