Billings Pro Updating Payment Information Outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 2 months ago. Jun 14, 2018 - 13:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Jun 13, 2018 - 16:15 EDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Jun 11, 2018 - 13:56 EDT
Identified
Some customers are having issues adding new credit cards to their Billings Pro payment information. Please contact support if you are experiencing this issue, while we continue to work on a fix.
Posted 2 months ago. Jun 08, 2018 - 16:26 EDT
This incident affected: Billings Pro (Billings - Control Panel).