Unscheduled Maintenance
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 28, 2018 - 11:40 EST
Identified
Our Cloud Provider is applying crucial security update to our servers. Daylite Cloud is unavailable at the moment.
Posted 3 months ago. Feb 28, 2018 - 11:13 EST