DNS system issue
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 13, 2018 - 19:13 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Oct 13, 2018 - 17:59 EDT
Investigating
We're looking into an issue with the DNS system used by some Marketcircle services.
Posted 2 months ago. Oct 13, 2018 - 17:09 EDT
This incident affected: Billings Pro (Billings - Desktop Sync) and Main Website.