Partial sync outage
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 10 days ago. Jul 10, 2019 - 09:29 EDT
Investigating
We are currently investigating this issue.
Posted 10 days ago. Jul 10, 2019 - 09:17 EDT
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync).