Billings Pro Timecard Degraded Performance
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 5 months ago. May 07, 2019 - 17:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 5 months ago. May 07, 2019 - 16:51 EDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. May 07, 2019 - 16:37 EDT