Change Password Not Working
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 29, 2018 - 19:51 EST
Update
We are continuing to investigate this issue.
Posted 3 months ago. Nov 29, 2018 - 19:50 EST
Investigating
Users may receive an error message when attempting to change their password through the Daylite account manager. We are currently investigating the issue.
Posted 3 months ago. Nov 29, 2018 - 16:11 EST
This incident affected: Daylite Cloud (Account Manager).