Login and Account Manager issues
Incident Report for Marketcircle
Resolved
This incident has been resolved.
Posted May 17, 2021 - 11:04 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2021 - 10:56 EDT
This incident affected: Daylite Cloud (Mac & iPhone/iPad Sync, Account Manager).